Рассказы о велопоходах

Системные требования JBZoo. Требования к хостингу необходимой версии PHP, Joomla, Zoo

Опубликовано: 11.04.2018

На какую версию Joomla можно установить приложение JBZoo?

Рекомендуемая платформа для работы JBZoo — Joomla 3.x+, или 2.5.x (на свой страх и риск).

Учтите, что версии Joomla 1.5, 1.6, 1.7 и 2.5 уже не развиваются и официально считаются устаревшими. Разработчики CMS не рекомендуют их использовать и больше не развивают их, т.к. они имеют проблемы и их больше не будут решать.

С какой версией Zoo совместимо?

Рекомендуемая версия Zoo: 3.3.14 и выше. Последнюю официально совместимую версию Zoo всегда можно найти в разделе загрузки. Мы очень тщательно следим за версиями компонента, поэтому практически всегда наше приложение полностью совместимо с последний официальной версией от Yootheme.


Введение в JBZoo

Нужно ли покупать Zoo?

JBZoo прекрасно работает с последней бесплатной версией ZOO , поэтому вам не нужно приобретать платную версию у YOOTheme. Все необходимо можно скачать у них или у нас в личном кабинете.

Имеет ли значение версия PHP?

5.2.x — Не рекомендуется, т.к официально устарела еще в 2010 году. 5.3.x — Имеет множество багов, нормально работает только под Linux. Устарел в 2013-2014 годах. 5.4.x и выше — Рекомендуется!

Настоятельно рекомендуем использовать Open Server для локальной разработки. Denwer устарел несколько лет назад и использует очень старое программное обеспечение.

Дополнительные требования?

Ваш веб-сервер обязательно должен работать с модулем ionCube. Он есть практически на всех хостингах (можете узнать у вашей техподдержки). Либо его включают по первой просьбе. Обязательные расширения для PHP: JSON, mbString, GD, simpleXML, cURL, dom. Обычно они всегда есть у любого хостера. С вашего веб-сервера должен быть доступен наш сайт . Эта необходимость обусловлена тем, что приложение JBZoo нуждается в активации и проверке регистрационных данных из панели управления сайта. Ограничение по памяти — не ниже 64 мб (32мб — крайний минимум). Желательно (но совсем не обязательно), чтобы был установлен APC (ускоритель PHP кода). Либо eAccelerator, xCache.

Также можно проверить соответствие хостинга с помощью инструмента в компоненте Zoo

Для этого необходимо сделать несколько простых шагов:

Перейдите по ссылке в панели администратора: 

/administrator/index.php?option=com_zoo&controller=manager&task=checkrequirements&tmpl=component Нажмите на вкладку Шестеренки. Кликните по кнопке Проверка требований.

Вы увидите соответствие требованиям компонента Zoo (на основе которого сделан JBZoo).

 

rss